tunerstudio not connecting

Fuel Supply & Ignition Systems

Moderator: Tom Notch

Post Reply
Posts: 324
Joined: Sun Aug 29, 2004 12:53 pm

tunerstudio not connecting

Post by ruff » Sat Apr 08, 2017 9:16 am

I just registered to tunerstudio because my laptop only has usb.
registered fine, but then still no connection to the ECU.
tried 2 usb cables... still no connection...
when i try to upload new firmware he tries the FDXX, but no connection possible

the usb ports on my laptop work... just used it with a HD...



User avatar
Posts: 21913
Joined: Sat Feb 16, 2002 3:01 am
Location: Van Alstyne, Texas

Re: tunerstudio not connecting

Post by Piledriver » Sat Apr 08, 2017 2:19 pm

The FTDI needs the driver installed first to be usable, theres a link on the website.
The std RS232 serial works very well these days.(was recently rewritten)

Do make sure to first assign the USB serial device to a specific serial port#, the port detection in TS leaves much to be desired. (done in control panel>system>device manager in Windows)
That can be doe in Linux as well via a udev rule.
TS works much better with a known serial port.
(This includes the built-in adapter in MS3s)
I, for one, regularly embrace our new robot overlords, as I am the guy fixing the robots...

User avatar
Chip Birks
Posts: 2981
Joined: Wed Mar 12, 2008 7:59 pm
Location: Pleasant Grove, Utah

Re: tunerstudio not connecting

Post by Chip Birks » Sat Apr 08, 2017 4:23 pm

I just went through the same exact thing. New laptop, just had to download the drivers from DIYautotune. Not a big deal after that. I have tested on my MS3-Pro, as well as an MS2 with the adaptor. Works fine.

User avatar
Posts: 1310
Joined: Sat Jun 22, 2002 2:01 am
Location: Houston, TX

Re: tunerstudio not connecting

Post by Jadewombat » Thu Apr 13, 2017 10:33 pm

What are you using to crossover to a 9 pin? You have a USB to 9 pin adapter and software for the adapter? The lights are flickering on the adapter? You're hooked directly to the ECU (not a bluetooth), correct?

User avatar
Dale M.
Posts: 1640
Joined: Mon Oct 05, 2009 10:09 am
Location: Just a Little Bit West Of Yosemite Valley

Re: tunerstudio not connecting

Post by Dale M. » Wed Apr 19, 2017 9:36 am

Check in Windows "device manager" to see what RS-232 port the USB adapter/cable is using... Might need to assign port number in tuner studio,,, Also check to see the there is NOT a "!" next to USB "device"...

Lives his life vicariously through his own self.
1970 "Kellison Sand Piper Roadster"

Posts: 324
Joined: Sun Aug 29, 2004 12:53 pm

Re: tunerstudio not connecting

Post by ruff » Wed Apr 26, 2017 6:37 am

it was a driver problem....
Solved now!!

Posts: 3
Joined: Sun Sep 10, 2017 11:13 am

Re: tunerstudio not connecting

Post by profab » Sun Sep 10, 2017 11:21 am

Hey i hope im allowed to post links here. Its a useful guide for you that explains step by step.
https://www.diyautotune.com/support/tec ... nerstudio/

Should be very useful, i tried this myself as i had the same problems. Anyway for future reference in case another needs help you can always go there.

Hope it helps!
Custom parts, repairs and anything you can think of when it comes to repairing your car, a good place to go is Pro Fabrication. A reliable company from old cars to new.

Post Reply