Page 24 of 24

Re: My latest ride

Posted: Sun Mar 18, 2018 7:14 am
by buguy
Haha! It was 45* here Thursday morning when I went to work. I was shivering!

Re: My latest ride

Posted: Wed Apr 04, 2018 6:00 am
by madmike
Back to winter up here we got dumped on :roll: 10+ " of the white stuff :roll: :( :cry:
so no turbo news for me :| :lol:

Re: My latest ride

Posted: Fri Apr 06, 2018 6:08 am
by John S.
What's the fastest you ever got the rail dragster to go? Was it only a two speed sand set-up?

Re: My latest ride

Posted: Sat Apr 07, 2018 6:16 am
by madmike
Hey John, fastest I ever went 1/8th mile was 7.9 @ 88mph with the sand trans,, had to coast across the finish line :lol:
Why do u ask? :lol:

Re: My latest ride

Posted: Sat Apr 14, 2018 8:11 am
by madmike
Great,Now I have to add up what I've got in a Stroker motor ,,, but remember it took years to build cuz I $croung the swap meets :lol:

Re: My latest ride

Posted: Sun Apr 15, 2018 6:16 am
by madmike
I'm Amish this wknd :lol: , 'No Power" just the Generator :roll:
so sick of winter :evil: another 14+" of snow & ice :cry: tress on the ground/wires ect.. good old Michigan or Mother Nature is Bi-Polar and off her Med's :lol: :lol:

Re: My latest ride

Posted: Sun Apr 15, 2018 8:05 am
by buguy
That's so crazy. It was like 88 degrees or something here yesterday.

Re: My latest ride

Posted: Mon Apr 16, 2018 7:28 am
by madmike
Crazy ain't the word I'd use,,,, today were getting another 6 inches :evil: :cry: :cry: :cry: :(
Power is back on ,,for now ,, only out for 29 1/2 hours :lol:

Re: My latest ride

Posted: Mon Apr 16, 2018 10:17 am
by Clonebug
We have nothing but rain......... :roll: :cry: :cry:

Re: My latest ride

Posted: Mon Apr 16, 2018 10:38 am
by Ol'fogasaurus
madmike wrote:
Sat Apr 07, 2018 6:16 am
Hey John, fastest I ever went 1/8th mile was 7.9 @ 88mph with the sand trans,, had to coast across the finish line :lol:
Why do u ask? :lol:
Except for the grandstand, the safety barriers, some speakers and the wing; that pix of a singleton pass brought back a lot of memories; I go back to front engine rails only. Back in the day they drug the rails down to the end of the strip to push start them heading back to the start line. The driver's had to be careful turning around as they had so much caster in the front suspension that is could, and often did, collapse if they turned too tight and the trip was over; a lot of pushing and shoving to get things ready. The engine would be very warm by then so there was no funny stuff/head games like went on for a while and they would quickly line up and either the starter w/flag would point to each to see if they were ready or, later, the tree. I can remember seeing my first 200 mph pass (204 mph).

We always backed the truck in at the finish line as that was where all the speed was and the broken stuff would often fall off about where we were. Back then they cooked the tires pretty much the whole pass.

Things sure have changed!

Thanks, Lee

Re: My latest ride

Posted: Tue Apr 17, 2018 5:51 am
by madmike
:lol: That's showin your age O'l fog :lol: :lol: :lol: :lol:

Re: My latest ride

Posted: Sun Apr 22, 2018 6:03 am
by madmike
Finally got around to order the RLR Intake manifold,Photo coming when it arrives :wink:
now to place a Jeg's order for fittings and a new O2 sensor.

Re: My latest ride

Posted: Sun Apr 22, 2018 6:45 am
by buguy
Is that the one that has the ports for oil to go through it?

Re: My latest ride

Posted: Mon Apr 23, 2018 6:14 am
by madmike
Yes , has ports for oil :wink: , although I'm not having any issues with the Chassie Shops' intake ,, I just figure it with help and I'll have a spare intake for the 1915cc motor :lol: