Something is not right with my Weber DCOE please help

With Turbo and Super charging you can create massive horsepower with vw motors.

Moderator: seabeebuggy

Post Reply
advinnie
Posts: 743
Joined: Mon Jun 10, 2013 6:54 am
Location: Oxfordshire

Something is not right with my Weber DCOE please help

Post by advinnie » Fri Jan 12, 2018 8:36 am

Hi all I have a Weber 40 dcoe carb on my turbo bug. Before Xmas it was working fine but now something has gone wrong. The problem is at idle there is a lot of fuel pouring out of the auxiliary venturi. As far as I’m a where fuel coming out of the auxiliary Venturi means the main jets are active?
If the main jets are active that means the progression holds have been uncovered ?
Is my thinking correct?

66brm
Posts: 258
Joined: Mon Apr 12, 2010 8:55 pm
Location: Perth, Western Australia, The Southern Hemisphere

Re: Something is not right with my Weber DCOE please help

Post by 66brm » Fri Jan 12, 2018 8:48 am

What's your fuel pressure like? And check your float/needle and seat, may have crud in there letting excess fuel through

advinnie
Posts: 743
Joined: Mon Jun 10, 2013 6:54 am
Location: Oxfordshire

Re: Something is not right with my Weber DCOE please help

Post by advinnie » Fri Jan 12, 2018 11:48 am

That’s what I was thinking so changed the needle valve and washer for a new one, reset the the floats 8.5mm & 15mm drop and the fuel pressure is set at 3psi

madmike
Posts: 1487
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: Something is not right with my Weber DCOE please help

Post by madmike » Sat Jan 13, 2018 7:42 am

does sound like a piece of crap in the Inlet valve :roll: ? or the pressure went up? I've dropped the pressure to 2lbs before :wink:

advinnie
Posts: 743
Joined: Mon Jun 10, 2013 6:54 am
Location: Oxfordshire

Re: Something is not right with my Weber DCOE please help

Post by advinnie » Sat Jan 13, 2018 8:35 am

The new inlet valve has sorted it, well let’s just say it’s all up and going again

madmike
Posts: 1487
Joined: Mon Jul 24, 2006 5:11 pm
Location: Atlanta,Michigan

Re: Something is not right with my Weber DCOE please help

Post by madmike » Sun Jan 14, 2018 6:40 am

8)

Post Reply