Page 1 of 1

Something is not right with my Weber DCOE please help

Posted: Fri Jan 12, 2018 8:36 am
by advinnie
Hi all I have a Weber 40 dcoe carb on my turbo bug. Before Xmas it was working fine but now something has gone wrong. The problem is at idle there is a lot of fuel pouring out of the auxiliary venturi. As far as I’m a where fuel coming out of the auxiliary Venturi means the main jets are active?
If the main jets are active that means the progression holds have been uncovered ?
Is my thinking correct?

Re: Something is not right with my Weber DCOE please help

Posted: Fri Jan 12, 2018 8:48 am
by 66brm
What's your fuel pressure like? And check your float/needle and seat, may have crud in there letting excess fuel through

Re: Something is not right with my Weber DCOE please help

Posted: Fri Jan 12, 2018 11:48 am
by advinnie
That’s what I was thinking so changed the needle valve and washer for a new one, reset the the floats 8.5mm & 15mm drop and the fuel pressure is set at 3psi

Re: Something is not right with my Weber DCOE please help

Posted: Sat Jan 13, 2018 7:42 am
by madmike
does sound like a piece of crap in the Inlet valve :roll: ? or the pressure went up? I've dropped the pressure to 2lbs before :wink:

Re: Something is not right with my Weber DCOE please help

Posted: Sat Jan 13, 2018 8:35 am
by advinnie
The new inlet valve has sorted it, well let’s just say it’s all up and going again

Re: Something is not right with my Weber DCOE please help

Posted: Sun Jan 14, 2018 6:40 am
by madmike
8)