My 57 drag Bug

Do you like to go fast? Well get out of that stocker and build a hipo motor for your VW. Come here to talk with others who like to drive fast.
jacobnhra
Posts: 14
Joined: Thu Aug 12, 2010 1:16 pm

Re: My 57 drag Bug

Post by jacobnhra »

Got some work done.
You do not have the required permissions to view the files attached to this post.
User avatar
Chip Birks
Posts: 4001
Joined: Wed Mar 12, 2008 5:59 pm

Re: My 57 drag Bug

Post by Chip Birks »

Looking great!
Ol'fogasaurus
Posts: 17717
Joined: Mon Nov 13, 2006 10:17 pm

Re: My 57 drag Bug

Post by Ol'fogasaurus »

jacobnhra, I agree with Chip about the work but I am not sure about the lone long stiffening beads with no cross beading. The bottom pix with the two pieces with cross beading are good but if you look at what VW did with their stock floor the beading was across the floor not lengthwise. What I see is the floor wanting to "cup" as it is stood on.

Even the foot well in the stock VW pan is part of the stiffening features that VW put in. Also the body to pan's mounting flange is part of the strengthening of the floor. This kind of stuff can be very complicated and it is easy to miss some things.

The work you have done is really well done!

My opinions are worth what you paid for them.

Lee
jacobnhra
Posts: 14
Joined: Thu Aug 12, 2010 1:16 pm

Re: My 57 drag Bug

Post by jacobnhra »

Got a few things going. I need to decide on a tire size for the front and get them coming.
You do not have the required permissions to view the files attached to this post.
jacobnhra
Posts: 14
Joined: Thu Aug 12, 2010 1:16 pm

Re: My 57 drag Bug

Post by jacobnhra »

Finally got the rear fenders hung.
You do not have the required permissions to view the files attached to this post.
User avatar
Chip Birks
Posts: 4001
Joined: Wed Mar 12, 2008 5:59 pm

Re: My 57 drag Bug

Post by Chip Birks »

Its awesome to see this taking shape! Keep at it!
motomwo
Posts: 3
Joined: Sun Sep 01, 2019 6:25 pm

Re: My 57 drag Bug

Post by motomwo »

Looking great! Any updates!
jacobnhra
Posts: 14
Joined: Thu Aug 12, 2010 1:16 pm

Re: My 57 drag Bug

Post by jacobnhra »

A few pics of the tubs.
You do not have the required permissions to view the files attached to this post.
User avatar
Chip Birks
Posts: 4001
Joined: Wed Mar 12, 2008 5:59 pm

Re: My 57 drag Bug

Post by Chip Birks »

Looks great! Thanks for the update! What are you thinking you'll do for the powerplant?
jacobnhra
Posts: 14
Joined: Thu Aug 12, 2010 1:16 pm

Re: My 57 drag Bug

Post by jacobnhra »

I'm puting the stuff together for a 2276. Ive got a pair of Panchito's cut to 45 cc. Not sure about a cam yet, I planned on an fk89 but their not real big heads so I don't know. I have a set of 44idfs I can top it with. Nothing super complex to start. Just something to shake the car down with.
motomwo
Posts: 3
Joined: Sun Sep 01, 2019 6:25 pm

Re: My 57 drag Bug

Post by motomwo »

Did you finish this project? Any updates? I would sure like to see it.

Marty
Post Reply